aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner2021-05-04 07:44:05 -0500
committerEfraim Flashner2021-05-04 07:44:05 -0500
commit4eb09d4fce950181e1726901620f1d67ff4a0d61 (patch)
tree975356121e9e3126461c3f7eb5b5c9f1f8096eb7 /gn/packages/bioinformatics.scm
parentac63d819bfba8a9a540abe2c91b730cbafe60e6f (diff)
downloadguix-bioinformatics-4eb09d4fce950181e1726901620f1d67ff4a0d61.tar.gz
gn: genome browser tests good
Diffstat (limited to 'gn/packages/bioinformatics.scm')
-rw-r--r--gn/packages/bioinformatics.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index a8ebe68..58110a7 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages elf)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -1609,10 +1610,12 @@ multiple sequence alignment.")
(substitute* (cons* "inc/cgi_build_rules.mk"
(find-files "." "makefile"))
(("CGI_BIN\\}-\\$\\{USER") "CGI_BIN_USER"))
+
;; Force linking with freetype.
(substitute* "inc/common.mk"
(("libpng-config --ldflags") "pkg-config --libs libpng freetype2")
(("libpng-config --I_opts") "pkg-config --cflags-only-I libpng freetype2"))
+
;; Force the trash location.
(substitute* (cons*
"utils/qa/showTracks"
@@ -1620,12 +1623,11 @@ multiple sequence alignment.")
"hg/js/hgTracks.js"
(find-files "." "\\.c$"))
;; This line is specifically needed as-is.
- (("\\.\\./trash") "/var/www/html/trash"))
+ (("\\.\\./trash") "/var/cache/genome"))
#t)))
;; Install happens during the 'build phase.
;; Install the website files too
- ;; rsync -avzP rsync://hgdownload.cse.ucsc.edu/htdocs/ /var/www/html/
(replace 'install
(lambda _
(invoke "make" "doc-install")
@@ -1639,15 +1641,13 @@ multiple sequence alignment.")
"include /var/lib/genome/hg.conf\n")))
#t)))
(add-after 'install 'create-symlink
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Some trash locations are hardcoded as "../trash"
- ;(symlink "/var/www/html/trash"
- ; (string-append out "/trash"))
- (symlink "../html"
- (string-append out "/htdocs"))
- #t)))
- )))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir-p "htdocs")
+ ;; Fallback location for fonts.
+ (symlink (string-append (assoc-ref inputs "gs-fonts")
+ "/share/fonts/type1/ghostscript")
+ "htdocs/urw-fonts")
+ #t)))))
(inputs
`(("freetype" ,freetype)
("libpng" ,libpng)
@@ -1658,7 +1658,8 @@ multiple sequence alignment.")
("python2" ,python-2)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gs-fonts" ,gs-fonts)
+ ("pkg-config" ,pkg-config)
("python" ,python)
("rsync" ,rsync) ; For installing js files from the source checkout
("tcl" ,tcl)