aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorpjotrp2016-02-22 08:50:37 +0000
committerpjotrp2016-02-22 08:50:37 +0000
commit96706fd977738f6ca3eb981591ced6c7db833887 (patch)
tree618c5928f496dae736d0a9e1bb59c70e71a5b2dc /gn/packages/bioinformatics.scm
parenta51087788c1a5b87f1eff6ac3c1832b4725119db (diff)
downloadguix-bioinformatics-96706fd977738f6ca3eb981591ced6c7db833887.tar.gz
Moving genenetwork stuff into its own module
Diffstat (limited to 'gn/packages/bioinformatics.scm')
-rw-r--r--gn/packages/bioinformatics.scm151
1 files changed, 0 insertions, 151 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 896767b..43e61a2 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -47,45 +47,6 @@
#:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
-(define-public my-deploy
- (package
- (name "my-deploy")
- (version "0.0.1")
- (source #f)
- (build-system trivial-build-system)
- (arguments
- `(#:guile ,%bootstrap-guile
- #:modules ((guix build utils))
- #:builder
- (let* ((out (assoc-ref %outputs "out"))
- (bash (assoc-ref %build-inputs "bash"))
- (foo (string-append out "/foo")))
- (begin
- (use-modules (guix build utils))
- (mkdir out)
- (call-with-output-file foo
- (lambda (p)
- (format p
- "#!~a~%echo \"${GUIX_FOO} ${GUIX_BAR}\"~%"
- bash)))
- (chmod foo #o777)
- ;; wrap-program uses `which' to find bash for the wrapper
- ;; shebang, but it can't know about the bootstrap bash in
- ;; the store, since it's not named "bash". Help it out a
- ;; bit by providing a symlink it this package's output.
- (symlink bash (string-append out "/bash"))
- (setenv "PATH" out)
- (wrap-program foo `("GUIX_FOO" prefix ("hello")))
- (wrap-program foo `("GUIX_BAR" prefix ("world")))
- #t))))
- (inputs `(("bash" ,(search-bootstrap-binary "bash"
- (%current-system)))))
-
- (home-page #f)
- (synopsis #f)
- (description #f)
- (license #f)))
-
(define-public r-wgcna
(package
(name "r-wgcna")
@@ -307,118 +268,6 @@ association studies (GWAS).")
(license license:gpl3))))
-(define-public genenetwork1
- (let ((commit "d622c803b"))
- (package
- (name "genenetwork1")
- (version (string-append "1.0-" commit ))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/genenetwork/genenetwork.git")
- ;; (url "https://github.com/pjotrp/genenetwork.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "14fzfcm4vl20mlhxjslfa01i1nmxpk8lbxmfvpq6dyfc22ir62py"))))
- (propagated-inputs `(
- ("python" ,python-2) ;; probably superfluous
- ("r" ,r)
- ))
- (inputs `(
- ;; http://spring211.uthsc.edu/gn/thirdparty.tbz
- ;; graphviz-2.22.2 htmlgen json numarray-1.5.2 piddle PIL pp-1.5.7 pyx pyXLWriter svg
- ("mysql" ,mysql)
- ("nginx" ,nginx)
- ("graphviz" ,graphviz)
- ; ("python2-jinja2" ,python2-jinja2)
- ; ("python2-sqlalchemy" ,python2-sqlalchemy)
- ; ("python2-setuptools" ,python2-setuptools)
- ; ("python2-scipy" ,python2-scipy)
- ;; looks like python-numarray is not needed
- ; ("python2-numpy" ,python2-numpy)
- ; ("python2-pandas" ,python2-pandas)
- ; ("python2-passlib" ,python2-passlib)
- ; ("python2-redis" ,python2-redis)
- ; ("python2-requests" ,python2-requests)
- ; ("python2-simplejson" ,python2-simplejson)
- ; ("python2-pyyaml" ,python2-pyyaml)
- ;; python-yolk is not needed
- ("python2-pil" ,python2-pil)
- ("python2-numarray" ,python2-numarray)
- ("plink" ,plink) ;; gn1
- ; ("r-qtl" ,r-qtl)
- ))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; no 'setup.py test'
- (home-page "http://genenetwork.org/")
- (synopsis "Full genenetwork services")
- (description "Genenetwork installation sumo.")
- (license license:agpl3+))))
-
-(define-public genenetwork2
- (let ((commit "9e9475053"))
- (package
- (name "genenetwork2")
- (version (string-append "2.0-" commit ))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- ;; (url "https://github.com/genenetwork/genenetwork2.git")
- (url "https://github.com/pjotrp/genenetwork2.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "09hvy9mf4dnmkb8qg49viffzrxk53m2kr4r955m84dxaa5pdrjhd"))))
- (propagated-inputs `( ;; propagated for development purposes
- ("python" ,python-2) ;; probably superfluous
- ("r" ,r)
- ("redis" ,redis)
- ("mysql" ,mysql)
- ("gemma" ,gemma-git)
- ("pylmm-gn2" ,pylmm-gn2)
- ("plink2" ,plink-ng)
- ("nginx" ,nginx)
- ("python2-flask" ,python2-flask)
- ("python2-htmlgen-gn" ,python2-htmlgen-gn)
- ("python2-jinja2" ,python2-jinja2)
- ("python2-sqlalchemy" ,python2-sqlalchemy)
- ("python2-flask-sqlalchemy" ,python2-flask-sqlalchemy)
- ("python2-setuptools" ,python2-setuptools)
- ("python2-scipy" ,python2-scipy)
- ;; looks like python-numarray is not needed
- ("python2-mysqlclient" ,python2-mysqlclient)
- ("python2-numarray" ,python2-numarray)
- ("python2-numpy" ,python2-numpy)
- ("python2-pandas" ,python2-pandas)
- ("python2-parallel" ,python2-parallel)
- ("python2-passlib" ,python2-passlib)
- ("python2-piddle" ,python2-piddle)
- ("python2-redis" ,python2-redis)
- ("python2-requests" ,python2-requests)
- ("python2-rpy2" ,python2-rpy2)
- ("python2-scipy" ,python2-scipy)
- ("python2-simplejson" ,python2-simplejson)
- ("python2-pyyaml" ,python2-pyyaml)
- ("python2-xlsxwriter" ,python2-xlsxwriter)
- ;; python-yolk is not needed
- ("plink" ,plink)
- ("qtlreaper" ,qtlreaper)
- ("r-qtl" ,r-qtl)
- ))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; no 'setup.py test'
- (home-page "http://genenetwork.org/")
- (synopsis "Full genenetwork services")
- (description "Genenetwork installation sumo.")
- (license license:agpl3+))))
-
(define-public rdmd
(package
(name "rdmd")