aboutsummaryrefslogtreecommitdiff
path: root/arrayfire-newer-boost-compute.patch
diff options
context:
space:
mode:
authorEfraim Flashner2019-08-06 07:33:47 -0500
committerEfraim Flashner2019-08-06 07:33:47 -0500
commit83c0ba13d35055ff73620ec7163c6e862a06f805 (patch)
treec862ab5a35a50a0286eb0b03afda879cf22bb81e /arrayfire-newer-boost-compute.patch
parentb0926f0df4f76b24dbb99da3f10a87e606fac993 (diff)
downloadguix-bioinformatics-83c0ba13d35055ff73620ec7163c6e862a06f805.tar.gz
gn: Fix building arrayfire.
Diffstat (limited to 'arrayfire-newer-boost-compute.patch')
-rw-r--r--arrayfire-newer-boost-compute.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/arrayfire-newer-boost-compute.patch b/arrayfire-newer-boost-compute.patch
new file mode 100644
index 0000000..b08c121
--- /dev/null
+++ b/arrayfire-newer-boost-compute.patch
@@ -0,0 +1,33 @@
+https://sources.debian.org/data/main/a/arrayfire/3.3.2+dfsg1-4/debian/patches/Use-compute-library-from-Boost-1.61.patch
+
+From: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Date: Fri, 12 Aug 2016 08:35:19 +0100
+Subject: Use compute library from Boost 1.61.
+
+---
+ src/backend/opencl/CMakeLists.txt | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/backend/opencl/CMakeLists.txt b/src/backend/opencl/CMakeLists.txt
+index ded53bf..d7e3628 100644
+--- a/src/backend/opencl/CMakeLists.txt
++++ b/src/backend/opencl/CMakeLists.txt
+@@ -84,11 +84,13 @@ ADD_DEFINITIONS( -DBOOST_ALL_NO_LIB )
+ SET(Boost_USE_STATIC_LIBS OFF)
+ FIND_PACKAGE(Boost 1.48 REQUIRED)
+
+-OPTION(USE_SYSTEM_BOOST_COMPUTE "Use system BoostCompute" OFF)
+-IF(USE_SYSTEM_BOOST_COMPUTE)
+- FIND_PACKAGE(BoostCompute REQUIRED)
+-ELSE()
+- INCLUDE("${CMAKE_MODULE_PATH}/build_boost_compute.cmake")
++IF(Boost_VERSION VERSION_LESS "1.61")
++ OPTION(USE_SYSTEM_BOOST_COMPUTE "Use system BoostCompute" OFF)
++ IF(USE_SYSTEM_BOOST_COMPUTE)
++ FIND_PACKAGE(BoostCompute REQUIRED)
++ ELSE()
++ INCLUDE("${CMAKE_MODULE_PATH}/build_boost_compute.cmake")
++ ENDIF()
+ ENDIF()
+
+ SET( cl_kernel_headers