aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner2020-07-20 17:59:55 +0300
committerEfraim Flashner2020-07-20 17:59:55 +0300
commitc8d0a2ebcef90fc49f6d2e8e4ebfa26a8e047502 (patch)
treeb77e1c176775052109c3fc8d2307c8cce3ce53b7
parent788e5b8830066dace15156f95d274bae2c61b3a8 (diff)
downloadguix-bioinformatics-c8d0a2ebcef90fc49f6d2e8e4ebfa26a8e047502.tar.gz
gn: Upstream many mailman zope packages
-rw-r--r--gn/packages/mailman.scm472
1 files changed, 0 insertions, 472 deletions
diff --git a/gn/packages/mailman.scm b/gn/packages/mailman.scm
index 99e3cf9..d2d2187 100644
--- a/gn/packages/mailman.scm
+++ b/gn/packages/mailman.scm
@@ -389,70 +389,6 @@ validation.")
(description "Zope Component Architecture")
(license license:zpl2.1)))
-(define-public python-zope-component-bootstrap
- (package
- (inherit python-zope-component)
- (arguments `(#:tests? #f))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-configuration
- (package
- (name "python-zope-configuration")
- (version "4.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.configuration" version))
- (sha256
- (base32
- "0g6vrl7y27z9cj5xyrww9xlzk4npj55mgmlrcd9d2nj08jn2pw79"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
- ("python-zope-interface" ,python-zope-interface)
- ("python-zope-schema" ,python-zope-schema)))
- (native-inputs
- `(("python-manuel" ,python-manuel)
- ("python-zope-schema" ,python-zope-schema)
- ("python-zope-testing" ,python-zope-testing)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.configuration")
- (synopsis "Zope Configuration Markup Language (ZCML)")
- (description
- "Zope Configuration Markup Language (ZCML)")
- (license license:zpl2.1)))
-
-(define-public python-zope-configuration-bootstrap
- (package
- (inherit python-zope-configuration)
- (arguments `(#:tests? #f))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-interface
- (package
- (name "python-zope-interface")
- (version "5.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.interface" version))
- (sha256
- (base32
- "03nrl6b8cb600dnnh46y149awvrm0gxyqgwq5hdw3lvys8mw9r20"))))
- (build-system python-build-system)
- (arguments '(#:tests? #f)) ; test suite can't find python-zope-testing
- (native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-nose" ,python-nose)
- ("python-zope-event" ,python-zope-event)
- ("python-zope-testing" ,python-zope-testing)))
- (home-page "https://github.com/zopefoundation/zope.interface")
- (synopsis "Interfaces for Python")
- (description "Interfaces for Python")
- (license license:zpl2.1)))
-
(define-public python-dkimpy
(package
(name "python-dkimpy")
@@ -574,355 +510,6 @@ and changing its implementation. All users of the function, including those
that imported it, will see the change.")
(license license:zpl2.1)))
-(define-public python-zope-i18nmessageid
- (package
- (name "python-zope-i18nmessageid")
- (version "5.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.i18nmessageid" version))
- (sha256
- (base32
- "0ndhn4w1qgwkfbwf9vm2bgq418z5g0wmfsgl0d9nz62cd0mi8d4m"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-six" ,python-six)))
- (native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.i18nmessageid")
- (synopsis "Message Identifiers for internationalization")
- (description
- "This package provides facilities for declaring messages within program
-source text; translation of the messages is the responsiblitiy of the
-@code{zope.i18n} package.")
- (license license:zpl2.1)))
-
-(define-public python-zope-schema
- (package
- (name "python-zope-schema")
- (version "6.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.schema" version))
- (sha256
- (base32
- "09jg47bxhfg1ahr1jxb5y0cbiszyk1j6fn1r1r7s6svjl3lbryr0"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (if tests?
- (invoke "zope-testrunner" "--test-path=src")
- #t))))))
- (propagated-inputs
- `(("python-zope-event" ,python-zope-event)
- ("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
- ("python-zope-testing" ,python-zope-testing)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.schema")
- (synopsis "Zope.interface extension for defining data schemas")
- (description
- "Schemas extend the notion of interfaces to detailed descriptions of
-Attributes (but not methods). Every schema is an interface and specifies the
-public fields of an object. A field roughly corresponds to an attribute of a
-Python object. But a Field provides space for at least a title and a
-description. It can also constrain its value and provide a validation method.
-Besides you can optionally specify characteristics such as its value being
-read-only or not required.")
- (license license:zpl2.1)))
-
-(define-public python-py3dns
- (package
- (name "python-py3dns")
- (version "3.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "py3dns" version))
- (sha256
- (base32
- "1r25f0ys5p37bhld7m7n4gb0lrysaym3w318w2f8bncq7r3d81qz"))))
- (build-system python-build-system)
- ;; This package wants to read /etc/resolv.conf. We can't patch it without
- ;; removing functionality so we copy from Nix and "just don't build it".
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* "setup.py"
- (("import DNS") "")
- (("DNS.__version__") (string-append "\"" ,version "\"")))
- #t)))
- #:tests? #f)) ; Also skip the tests.
- (home-page "https://launchpad.net/py3dns")
- (synopsis "Python 3 DNS library")
- (description "This Python 3 module provides a DNS API for looking up DNS
-entries from within Python 3 modules and applications. This module is a
-simple, lightweight implementation.")
- (license license:psfl)))
-
-(define-public python-zope-proxy
- (package
- (name "python-zope-proxy")
- (version "4.3.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.proxy" version))
- (sha256
- (base32
- "14h7nyfbl5vpfk0rbviy4ygdfx0yx5kncvg6jpbdb0dhwna0ssm6"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-zope-security" ,python-zope-security-bootstrap)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.proxy")
- (synopsis "Generic Transparent Proxies")
- (description "@code{zope.proxy} is implemented via a C extension module,
-which lets it do things like lie about its own __class__ that are difficult in
-pure Python (and were completely impossible before metaclasses).")
- (license license:zpl2.1)))
-
-(define-public python-zope-proxy-bootstrap
- (package
- (inherit python-zope-proxy)
- (arguments `(#:tests? #f))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-testrunner
- (package
- (name "python-zope-testrunner")
- (version "5.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.testrunner" version))
- (sha256
- (base32
- "0jyyf1dcz156q95x2y7yw2v420q2xn3cff0c5aci7hmdmcbn0gc7"))))
- (build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; Tests can't find zope.exceptions.
- (propagated-inputs
- `(("python-six" ,python-six)
- ("python-zope-exceptions" ,python-zope-exceptions)
- ("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-zope-testing" ,python-zope-testing)))
- (home-page "https://github.com/zopefoundation/zope.testrunner")
- (synopsis "Zope testrunner script")
- (description "This package provides a flexible test runner with layer
-support for the Zope framework.")
- (license license:zpl2.1)))
-
-(define-public python-zope-testrunner-bootstrap
- (package
- (inherit python-zope-testrunner)
- (arguments `(#:tests? #f))
- (propagated-inputs
- `(("python-six" ,python-six)
- ("python-zope-exceptions" ,python-zope-exceptions-bootstrap)))
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-exceptions
- (package
- (name "python-zope-exceptions")
- (version "4.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.exceptions" version))
- (sha256
- (base32
- "1nkgfwawswmyc6i0b8g3ymvja4mb507m8yhid8s4rbxq3dmqhwhd"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "zope-testrunner" "--test-path=src"))))))
- (propagated-inputs
- `(("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-zope-testrunner" ,python-zope-testrunner-bootstrap)))
- (home-page "https://github.com/zopefoundation/zope.exceptions")
- (synopsis "Zope Exceptions")
- (description "This package contains exception exceptions and
- implementations which are so general purpose that they don't belong in Zope
- application-specific packages.")
- (license license:zpl2.1)))
-
-(define-public python-zope-exceptions-bootstrap
- (package
- (inherit python-zope-exceptions)
- (arguments `(#:tests? #f))
- (propagated-inputs `())
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-testing
- (package
- (name "python-zope-testing")
- (version "4.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.testing" version))
- (sha256
- (base32
- "1sh3c3i0m8n8fnhqiry0bk3rr356i56ry7calmn57s1pvv8yhsyn"))))
- (build-system python-build-system)
- (home-page "https://github.com/zopefoundation/zope.testing")
- (synopsis "Zope testing helpers")
- (description "This package provides a number of Zope testing helpers")
- (license license:zpl2.1)))
-
-(define-public python-persistent
- (package
- (name "python-persistent")
- (version "4.6.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "persistent" version))
- (sha256
- (base32
- "0imm9ji03lhkpcfmhid7x5209ix8g2rlgki9ik1qxks4b8sm8gzq"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-cffi" ,python-cffi)
- ("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-manuel" ,python-manuel)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/persistent/")
- (synopsis "Translucent persistent objects")
- (description "This package contains a generic persistence implementation for
-Python. It forms the core protocol for making objects interact
-\"transparently\" with a database such as the ZODB.")
- (license license:zpl2.1)))
-
-(define-public python-zope-location
- (package
- (name "python-zope-location")
- (version "4.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.location" version))
- (sha256
- (base32
- "1b40pzl8v00d583d3gsxv1qjdw2dhghlgkbgxl3m07d5r3izj857"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "zope-testrunner" "--test-path=src" "\\[]"))))))
- (propagated-inputs
- `(("python-zope-interface" ,python-zope-interface)
- ("python-zope-proxy" ,python-zope-proxy)
- ("python-zope-schema" ,python-zope-schema)))
- (native-inputs
- `(("python-zope-component" ,python-zope-component-bootstrap)
- ("python-zope-configuration" ,python-zope-configuration-bootstrap)
- ("python-zope-copy" ,python-zope-copy-bootstrap)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.location/")
- (synopsis "Zope Location")
- (description "In Zope3, \"locations\" are special objects that have a
-structural location.")
- (license license:zpl2.1)))
-
-(define-public python-zope-location-bootstrap
- (package
- (inherit python-zope-location)
- (arguments `(#:tests? #f))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-zope-security
- (package
- (name "python-zope-security")
- (version "5.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "zope.security" version))
- (sha256
- (base32
- "11lfw67cigscfax9c5j63xcvz2qcj724zx5fcdqyc94am2glim0h"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-zope-component" ,python-zope-component)
- ("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
- ("python-zope-interface" ,python-zope-interface)
- ("python-zope-location" ,python-zope-location)
- ("python-zope-proxy" ,python-zope-proxy)
- ("python-zope-schema" ,python-zope-schema)))
- (native-inputs
- `(("python-btrees" ,python-btrees)
- ("python-zope-component" ,python-zope-component-bootstrap)
- ("python-zope-configuration" ,python-zope-configuration-bootstrap)
- ("python-zope-location" ,python-zope-location-bootstrap)
- ("python-zope-testing" ,python-zope-testing)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/zope.security")
- (synopsis "Zope Security Framework")
- (description "The security framework provides a generic mechanism to
-implement security policies on Python objects.")
- (license license:zpl2.1)))
-
-(define-public python-zope-security-bootstrap
- (package
- (inherit python-zope-security)
- (arguments `(#:tests? #f))
- (propagated-inputs
- `(;("python-zope-component" ,python-zope-component-bootstrap)
- ("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
- ("python-zope-interface" ,python-zope-interface)
- ;("python-zope-location" ,python-zope-location)
- ("python-zope-proxy" ,python-zope-proxy-bootstrap)
- ("python-zope-schema" ,python-zope-schema)))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-manuel
- (package
- (name "python-manuel")
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "manuel" version))
- (sha256
- (base32
- "1bdzay7j70fly5fy6wbdi8fbrxjrrlxnxnw226rwry1c8a351rpy"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-six" ,python-six)))
- (native-inputs
- `(("python-zope-testing" ,python-zope-testing)))
- (home-page "https://pypi.org/project/manuel/")
- (synopsis "Build tested documentation")
- (description
- "Manuel lets you mix and match traditional doctests with custom test syntax.")
- (license license:asl2.0)))
-
(define-public python-zope-copy
(package
(name "python-zope-copy")
@@ -954,65 +541,6 @@ implement security policies on Python objects.")
"This package provides a pluggable mechanism for copying persistent objects.")
(license license:zpl2.1)))
-(define-public python-zope-copy-bootstrap
- (package
- (inherit python-zope-copy)
- (arguments `(#:tests? #f))
- (native-inputs `())
- (properties `((hidden? . #t)))))
-
-(define-public python-btrees
- (package
- (name "python-btrees")
- (version "4.7.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "BTrees" version))
- (sha256
- (base32
- "0iiq0g9k1g6qgqq84q9h6639vlvzznk1rgdm0rfcnnqkbkmsbr3w"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-persistent" ,python-persistent)
- ("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-persistent" ,python-persistent)
- ("python-transaction" ,python-transaction)
- ("python-zope-testrunner" ,python-zope-testrunner)))
- (home-page "https://github.com/zopefoundation/BTrees")
- (synopsis "Scalable persistent object containers")
- (description
- "This package contains a set of persistent object containers built around a
-modified BTree data structure. The trees are optimized for use inside ZODB's
-\"optimistic concurrency\" paradigm, and include explicit resolution of
-conflicts detected by that mechanism.")
- (license license:zpl2.1)))
-
-(define-public python-transaction
- (package
- (name "python-transaction")
- (version "3.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "transaction" version))
- (sha256
- (base32
- "0bdaks31bgfh78wnj3sij24bfysmqk25crsis6amz8kzrc0d82iv"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-zope-interface" ,python-zope-interface)))
- (native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-mock" ,python-mock)
- ("python-nose" ,python-nose)))
- (home-page "https://github.com/zopefoundation/transaction")
- (synopsis "Transaction management for Python")
- (description "This package contains a generic transaction implementation
-for Python. It is mainly used by the ZODB.")
- (license license:zpl2.1)))
-
(define-public python-mailmanclient-3.3
(package
(inherit python-mailmanclient)