aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner2021-08-02 19:32:24 +0300
committerEfraim Flashner2021-08-02 19:32:24 +0300
commit095e987300cb18c0797854c6ccb71b3dbfe76f4a (patch)
tree837c309b8804ea5fbb237702a5d08a8a9626104e
parent20dd6613c8f8d804474b66bece63014b9fb4300f (diff)
downloadguix-bioinformatics-095e987300cb18c0797854c6ccb71b3dbfe76f4a.tar.gz
gn: gfaffix: Don't hardcode rust-handlegraph package version
-rw-r--r--gn/packages/bioinformatics.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 3d6a062..dfa3b1e 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -485,11 +485,11 @@ reads.")
(modify-phases %standard-phases
(add-after 'unpack 'adjust-dependency-version
(lambda* (#:key inputs #:allow-other-keys)
- ;; TODO: Replace the hardcoded version with logic.
- (substitute* "Cargo.toml"
- (("\"0.7\"")
- "{ version = \"0.7.0-alpha.9\" }"))
- #t)))))
+ (let ((handlebar-version ,(package-version rust-handlegraph-0.7)))
+ (substitute* "Cargo.toml"
+ (("\"0.7\"")
+ (string-append "{ version = \"" handlebar-version "\" }")))
+ #t))))))
(home-page "https://github.com/marschall-lab/GFAffix")
(synopsis "Identify walk-preserving shared affixes in variation graphs")
(description