aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki2018-03-26 17:47:21 +0300
committerMuriithi Frederick Muriuki2018-03-26 17:47:21 +0300
commit2c38581c2dcfa3c224f192bfff2c00d87afc8661 (patch)
tree4b65562ef8b1a04fe272d94ef572ea739c6a7e81
parentdb02f79948482d4060afcce4ddb69efeabf1b465 (diff)
downloadguix-bioinformatics-2c38581c2dcfa3c224f192bfff2c00d87afc8661.tar.gz
gn: Update genenetwork3 definition
* gn/packages/genenetwork.scm (genenetwork3): Update package definition. - Deactivate all packages that need Python 2 - Change the source uri for the package definition - Change the commit hash - Change the sha256 hash - Comment out the processing for pylmmcmd in the 'fix-paths' phase
-rw-r--r--gn/packages/genenetwork.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 9aa723f..d605dd4 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -396,20 +396,24 @@ location of a putative QTL.")
(define-public genenetwork3
- (let ((commit "1538ffd33af19e6ac922b4ee85fe701408968dfd"))
+ (let (;; (commit "1538ffd33af19e6ac922b4ee85fe701408968dfd")
+ (commit "5bff4f49dffb4ac982d36cd0d39e0a9ec6bc66e9"))
(package
(name "genenetwork3")
(version (string-append "2.10rc5-" (string-take commit 7) ))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://pjotrp@gitlab.com/genenetwork/gn2_diet.git")
+ (url "https://github.com/fredmanglis/genenetwork2.git")
+ ;; (url "https://pjotrp@gitlab.com/genenetwork/gn2_diet.git")
;; (url "https://github.com/genenetwork/genenetwork2_diet.git")
(commit commit)))
(file-name (string-append name "-" version))
(sha256
(base32
- "0ji929xgzypyhchcfy9xa1sz04w322ibs2khc8s3qiddxjqdglrz"))))
+ "0klgjra2qisfzs8mk0s8vzdr190l4n56xcm66dk0asqs7zswi8di"
+ ;; "0ji929xgzypyhchcfy9xa1sz04w322ibs2khc8s3qiddxjqdglrz"
+ ))))
(propagated-inputs ;; propagated for development purposes
`( ;; Agnostic to Python
("r" ,r)
@@ -436,6 +440,7 @@ location of a putative QTL.")
;; With Python3 support
+ ("python-wrapper" ,python-wrapper)
("gunicorn" ,gunicorn)
("python-rpy2" ,python-rpy2)
("python-flask" ,python-flask)
@@ -458,12 +463,12 @@ location of a putative QTL.")
;; Without Python3 support
- ("python-qtlreaper" ,python-qtlreaper) ;; Run as an external program
- ("pylmm-gn2" ,pylmm-gn2) ;; To be run as an external python2 program
- ("python2-pil1" ,python2-pil1) ; should move to pillow some day. Run as external python2 program
- ("python2-numarray" ,python2-numarray) ;; Update gn2 code and drop this (IMPORTANT)
- ("python2-piddle-gn" ,python2-piddle-gn) ;; Run as external python2 program
- ("python2-htmlgen-gn" ,python2-htmlgen-gn) ;; pjotrp and zsloan to give directions
+ ;; ("python-qtlreaper" ,python-qtlreaper) ;; Run as an external program
+ ;; ("pylmm-gn2" ,pylmm-gn2) ;; To be run as an external python2 program
+ ;; ("python2-pil1" ,python2-pil1) ; should move to pillow some day. Run as external python2 program
+ ;; ("python2-numarray" ,python2-numarray) ;; Update gn2 code and drop this (IMPORTANT)
+ ;; ("python2-piddle-gn" ,python2-piddle-gn) ;; Run as external python2 program
+ ;; ("python2-htmlgen-gn" ,python2-htmlgen-gn) ;; pjotrp and zsloan to give directions
;; Removed packages
@@ -500,9 +505,9 @@ location of a putative QTL.")
(string-append
(assoc-ref inputs "genenetwork2-files-small")
"/share/genenetwork2" ))
- (pylmmcmd
- (string-append
- (assoc-ref inputs "pylmm-gn2") "/bin/pylmm_redis"))
+ ;; (pylmmcmd
+ ;; (string-append
+ ;; (assoc-ref inputs "pylmm-gn2") "/bin/pylmm_redis"))
(plink2cmd
(string-append
(assoc-ref inputs "plink-ng-gn") "/bin/plink2"))
@@ -518,7 +523,7 @@ location of a putative QTL.")
(("^PLINK_COMMAND =.*")
(string-append "PLINK_COMMAND = \"" plink2cmd "\"\n" ))
(("^GEMMA_COMMAND =.*")
- (string-append "GEMMA_COMMAND = \"" gemmacmd "\"\n" )))))))
+ (string-append "GEMMA_COMMAND = \"" gemmacmd "\"\n")))))))
#:tests? #f)) ; no 'setup.py test'
(home-page "http://genenetwork.org/")
(synopsis "Full genenetwork services")