aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi2023-08-04 09:28:29 +0300
committerFrederick Muriuki Muriithi2023-08-04 10:20:09 +0300
commitf7fcbbcc014686ac597b783a8dcb38b43024b9d6 (patch)
treefcd69ffe3113c95f1dffa4a26dd5a65f9689caf9 /setup.py
downloadgn-auth-f7fcbbcc014686ac597b783a8dcb38b43024b9d6.tar.gz
Initialise the repository.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..52a928e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+#!/usr/bin/env python
+"""Setup script for GeneNetwork Auth package."""
+from setuptools import setup
+from setup_commands import RunTests
+
+long_description = """
+GeneNetwork-Auth project is the authentication/authorisation server to be used
+across all GeneNetwork services.
+"""
+
+setup(author="Frederick M. Muriithi",
+ author_email="fredmanglis@gmail.com",
+ description=(
+ "Authentication/Authorisation server for GeneNetwork Services."),
+ install_requires=[
+ "argon2-cffi>=20.1.0"
+ "click"
+ "Flask==1.1.2"
+ "mypy==0.790"
+ "mypy-extensions==0.4.3"
+ "mysqlclient==2.0.1"
+ "pylint==2.5.3"
+ "pymonad"
+ "redis==3.5.3"
+ "requests==2.25.1"
+ "flask-cors==3.0.9"
+ "xapian-bindings"
+ ],
+ scripts=[],
+ license="AGPLV3",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ name="GeneNetwork-Auth",
+ packages=[
+ "gn_auth",
+ "gn_auth.auth",
+ "tests"
+ ],
+ url="https://github.com/genenetwork/gn-auth",
+ version="0.0.0",
+ tests_require=["pytest", "hypothesis"],
+ cmdclass={
+ "run_tests": RunTests ## testing
+ })