aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 11 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 98a076f..9396f59 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,12 @@
#!/usr/bin/env python
"""Basic setup script for gn3"""
from setuptools import setup # type: ignore
+from setup_commands import RunTests
+def long_description():
+ """Retrieve long description from the README file."""
+ with open('README.md', encoding="utf-8") as readme:
+ return readme.read()
setup(author='Bonface M. K.',
author_email='me@bonfacemunyoki.com',
@@ -19,12 +24,11 @@ setup(author='Bonface M. K.',
"redis==3.5.3"
"requests==2.25.1"
"scipy==1.6.0"
- "sqlalchemy-stubs==0.4"
"plotly==4.14.3"
"flask-cors==3.0.9"
],
license='GPLV3',
- long_description=open('README.md').read(),
+ long_description=long_description(),
long_description_content_type='text/markdown',
name='gn3',
packages=[
@@ -35,4 +39,8 @@ setup(author='Bonface M. K.',
'tests'
],
url='https://github.com/genenetwork/genenetwork3',
- version='0.1')
+ version='0.1',
+ tests_require=["pytest", "hypothesis"],
+ cmdclass={
+ "run_tests": RunTests ## testing
+ })