aboutsummaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi2022-02-11 07:59:49 +0300
committerFrederick Muriuki Muriithi2022-02-11 08:08:59 +0300
commit5c5df8148fcaaed33a49a29cd303d739855ea251 (patch)
tree24d95e64d0fa3b0f60cd049248135e5ade785f0f /setup.cfg
parent651c8ad9ae20ab52e7ab694c0caa9d92774b49b5 (diff)
downloadgenenetwork3-5c5df8148fcaaed33a49a29cd303d739855ea251.tar.gz
Add scaffolding to run different types of tests
Enable running commands: - `python3 setup.py unit_check`: run the unit tests - `python3 setup.py integration_check`: run integration tests - `python3 setup.py performance_check`: run performance tests
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..b7593ce
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,5 @@
+[aliases]
+check = pytest
+unit_check = check --addopts=tests/unit
+integration_check = check --addopts=tests/integration
+performance_check = check --addopts=tests/performance