aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/gn_installation_notes.txt24
-rw-r--r--misc/requirements.txt4
-rw-r--r--wqflask/requirements.txt17
3 files changed, 20 insertions, 25 deletions
diff --git a/misc/gn_installation_notes.txt b/misc/gn_installation_notes.txt
index 2607f2b5..e31273b1 100644
--- a/misc/gn_installation_notes.txt
+++ b/misc/gn_installation_notes.txt
@@ -52,8 +52,23 @@ apt-file search _______
Install pip:
sudo apt-get install python-pip
-Install from requirements.txt:
-pip install -r gene/wqflask/requirements.txt -t ve27
+REMEMBER TO SOURCE VE BEFORE INSTALLING
+
+Comment out in requirements.txt:
+Reaper
+numarray
+
+Install from requirements.txt (after activating virtualenv):
+pip install -r gene/misc/requirements.txt
+
+When it hits error with install MySQL-Python, install libmysqlclient-dev:
+sudo apt-get install libmysqlclient-dev
+
+When hits error with numpy install python-dev:
+sudo apt-get install python-dev
+
+When hits error with scipy:
+sudo apt-get install libatlas-base-dev gfortran g++
============================================
@@ -116,10 +131,7 @@ Installing QTL Reaper
wget http://downloads.sourceforge.net/project/qtlreaper/qtlreaper/1.1.1/qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb
mv -v qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb qtlreaper-1.1.1.tar.gz
tar xvf qtlreaper-1.1.1.tar.gz (to unzip)
-python setup.py build
-sudo mkdir /home/zas1024/ve27/include/python2.7/Reaper
-sudo chown /home/zas1024/ve27/include/python2.7/Reaper (or whereever the directory is; the problem
-involved the fact that doing "sudo python setup.py install" doesn't install within the virtualenv)
+mkdir /home/zas1024/ve27/include/python2.7/Reaper
python setup.py install
===========================================
diff --git a/misc/requirements.txt b/misc/requirements.txt
index 0e892c05..ec02a2c2 100644
--- a/misc/requirements.txt
+++ b/misc/requirements.txt
@@ -9,7 +9,7 @@ Flask-WTF==0.8.3
Jinja2==2.6
MySQL-python==1.2.4
PyYAML==3.10
-Reaper==1.0
+#Reaper==1.0
Reindent==0.1.1
SQLAlchemy==0.8.0
WTForms==1.0.3
@@ -21,7 +21,7 @@ itsdangerous==0.17
logging-tree==1.2
logilab-astng==0.24.3
logilab-common==0.59.1
-numarray==1.5.2
+#numarray==1.5.2
numpy==1.7.0
passlib==1.6.1
pp==1.6.3
diff --git a/wqflask/requirements.txt b/wqflask/requirements.txt
deleted file mode 100644
index 4449c0e7..00000000
--- a/wqflask/requirements.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-Flask==0.9
-Jinja2==2.6
-#MySQL-python==1.2.3
-Piddle==0.1-dev
-PyYAML==3.10
-SQLAlchemy==0.7.9
-Werkzeug==0.8.3
-logging-tree==1.1
-nose==1.2.1
-numpy==1.6.2
-pp==1.6.3
-requests==0.13.3
-rpy2==2.3.1
-scipy==0.11.0
-simplejson==2.6.2
-wsgiref==0.1.2
-yolk==0.4.3