aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorzsloan2016-05-17 16:04:11 +0000
committerzsloan2016-05-17 16:04:11 +0000
commitf7520d9a6e05b103bab983c31ef0e53fad59f5e6 (patch)
treea1ba729c38a48806ca43540a960d655aaa9989e9 /setup.py
parent2dfc56250714cb494eb7f3072b1e7cae18edace4 (diff)
parent04afa563e6d53fe2a91ac2e6eb4af2f2fa5d5c3b (diff)
downloadgenenetwork2-f7520d9a6e05b103bab983c31ef0e53fad59f5e6.tar.gz
Merge branch 'staging' of github.com:genenetwork/genenetwork2 into development
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 1b11acc0..a9b71fab 100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,17 @@
+# Run setup from python - this script is used by the GNU Guix builder.
+
from setuptools import setup, find_packages
setup(name='genenetwork2',
version='2.0',
+ author = "The GeneNetwork Team",
+ author_email='rwilliams@uthsc.edu',
+ url = "https://github.com/genenetwork/genenetwork2/blob/master/README.md",
+ description = 'Website and tools for genetics.',
include_package_data=True,
- # packages=find_packages()
- packages=['wqflask']
- )
+ packages=['wqflask','etc'],
+ scripts=['bin/genenetwork2'],
+ # package_data = {
+ # 'etc': ['*.py']
+ # }
+)