aboutsummaryrefslogtreecommitdiff
path: root/misc/notes.txt
diff options
context:
space:
mode:
authorZachary Sloan2013-01-25 23:58:58 +0000
committerZachary Sloan2013-01-25 23:58:58 +0000
commit8e6fd914688625b686e8bd7da1704e96d83265f1 (patch)
treedec4b1cfb139e83a71adbcb4e982d7e231b50a8d /misc/notes.txt
parentb2c9e0a7dce0dc474704bf53ed70f9d92694d289 (diff)
downloadgenenetwork2-8e6fd914688625b686e8bd7da1704e96d83265f1.tar.gz
Added a bunch of things to notes
Diffstat (limited to 'misc/notes.txt')
-rw-r--r--misc/notes.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/misc/notes.txt b/misc/notes.txt
index e60102fc..3d4209c9 100644
--- a/misc/notes.txt
+++ b/misc/notes.txt
@@ -20,6 +20,14 @@ apt-cache show _______
Search for package with a specified file that can be installed with apt-get
apt-file search _______
+============================================
+
+Check which system packages are installed:
+dpkg -l | less
+
+============================================
+
+
To fix error "mysql_config not found":
sudo apt-get install libmysqlclient-dev
@@ -130,6 +138,9 @@ python setup.py install
Using Yolk
+Install Yolk:
+pip install yolk
+
Check packages installed in this virtual environment:
yolk -l
@@ -147,3 +158,12 @@ To iterate through dictionary items: for X, Y in MyDictionary.items():
Create symbolic link:
ln -s dir_to_link_to linking_dir
+
+===========================================
+
+Using grep:
+
+grep -ir (search string) (directory)
+
+-i ignores case
+-r searches recursively through subdirectories of directory you specify