aboutsummaryrefslogtreecommitdiff
path: root/misc/gn_installation_notes.txt
diff options
context:
space:
mode:
authorZachary Sloan2013-07-09 17:07:13 -0500
committerZachary Sloan2013-07-09 17:07:13 -0500
commitc0b7da4b4c2bd98353eb980402075318010a79a3 (patch)
tree52d6b2f29069b34a8b8940950f55ca3fbd451a36 /misc/gn_installation_notes.txt
parent05814fb8654d6479657db55c20a2d4851a7db931 (diff)
downloadgenenetwork2-c0b7da4b4c2bd98353eb980402075318010a79a3.tar.gz
Committing installation notes before editing them more
Diffstat (limited to 'misc/gn_installation_notes.txt')
-rw-r--r--misc/gn_installation_notes.txt24
1 files changed, 18 insertions, 6 deletions
diff --git a/misc/gn_installation_notes.txt b/misc/gn_installation_notes.txt
index 2607f2b5..e31273b1 100644
--- a/misc/gn_installation_notes.txt
+++ b/misc/gn_installation_notes.txt
@@ -52,8 +52,23 @@ apt-file search _______
Install pip:
sudo apt-get install python-pip
-Install from requirements.txt:
-pip install -r gene/wqflask/requirements.txt -t ve27
+REMEMBER TO SOURCE VE BEFORE INSTALLING
+
+Comment out in requirements.txt:
+Reaper
+numarray
+
+Install from requirements.txt (after activating virtualenv):
+pip install -r gene/misc/requirements.txt
+
+When it hits error with install MySQL-Python, install libmysqlclient-dev:
+sudo apt-get install libmysqlclient-dev
+
+When hits error with numpy install python-dev:
+sudo apt-get install python-dev
+
+When hits error with scipy:
+sudo apt-get install libatlas-base-dev gfortran g++
============================================
@@ -116,10 +131,7 @@ Installing QTL Reaper
wget http://downloads.sourceforge.net/project/qtlreaper/qtlreaper/1.1.1/qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb
mv -v qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb qtlreaper-1.1.1.tar.gz
tar xvf qtlreaper-1.1.1.tar.gz (to unzip)
-python setup.py build
-sudo mkdir /home/zas1024/ve27/include/python2.7/Reaper
-sudo chown /home/zas1024/ve27/include/python2.7/Reaper (or whereever the directory is; the problem
-involved the fact that doing "sudo python setup.py install" doesn't install within the virtualenv)
+mkdir /home/zas1024/ve27/include/python2.7/Reaper
python setup.py install
===========================================