33 Commits (f2e66663c2e00b482cdf5ba83173291d30363e7c)

Author SHA1 Message Date
Ludovic Courtès 1d84d7bf60
build: Require Guile >= 2.0.13. 4 years ago
Ludovic Courtès 06e3a5181e
doc: Mark zlib as mandatory, libbz2 as optional. 4 years ago
Mathieu Lirzin 397cd9cc41
doc: Update requirements in 'README'. 4 years ago
Marius Bakke e8d8ecde04
README: Replace http:// with https:// where applicable. 4 years ago
Ludovic Courtès 36626c556e
build: Require Guile >= 2.0.9. 5 years ago
Mathieu Lirzin 8efc35a890
maint: Fix invalid calls to 'info'. 5 years ago
Ludovic Courtès dd01fecd23 build: Automatically determine libgcrypt's file name. 6 years ago
Mathieu Lirzin 8c01b9d05a doc: Move most 'HACKING' informations into the manual. 7 years ago
Ludovic Courtès 230fda86a5 Document 'guix environment guix' in README. 7 years ago
Ludovic Courtès f0b98b8483 doc: Mention GNU Make as a requirement. 7 years ago
Ludovic Courtès 47c66da00b build: Require Guile >= 2.0.7. 7 years ago
Ian Denhardt 8a96bd4bb0 doc: Add a note about optional GnuTLS dependency. 7 years ago
Ludovic Courtès 288dca55a8 doc: Mention optional dependency on Guile-JSON. 7 years ago
Ludovic Courtès fa747b27fc doc: Update "Installing Guix from Guix". 7 years ago
John Darrington d17ef35620 doc: Replace /nix/store with /gnu/store in README. 7 years ago
Ludovic Courtès 47d347b725 doc: Mention 'gcc-toolchain' in README. 8 years ago
Ludovic Courtès 8db351e338 doc: Improve "Installing Guix from Guix" section. 8 years ago
Ludovic Courtès 8b2d9e5d44 doc: Improve build instructions in README and HACKING. 9 years ago
Ludovic Courtès 4a328f7342 doc: Mark 2.0.5 as being the minimum Guile version. 9 years ago
Konrad Hinsen d4c7486079 doc: Describe the build procedure in more detail. 9 years ago
Ludovic Courtès 43d8f4904c doc: Add note on installing Guix from Guix. 9 years ago
Ludovic Courtès e1b7096acd daemon: Build `nix-setuid-helper'. 9 years ago
Ludovic Courtès e9f6d6dd45 doc: Add new dependencies in `README'. 9 years ago
Ludovic Courtès c80e7e55b3 doc: Mention the pronunciation of "Guix". 9 years ago
Ludovic Courtès a65e3306d1 doc: Update `README'. 9 years ago
Ludovic Courtès d38487e9ca doc: Add a "Related software" section to `README'. 9 years ago
Ludovic Courtès f8348b91ad Turn Guix into "GNU Guix". 9 years ago
Ludovic Courtès d388c2c435 build: Require GNU libgcrypt. 9 years ago
Ludovic Courtès e76bdf8b87 build: Clearly mark Nixpkgs as optional. 9 years ago
Ludovic Courtès 7da7ae937e Augment `README'. 9 years ago
Ludovic Courtès a1e4a93693 Update list of dependencies. 10 years ago
Ludovic Courtès 4255d4e3c5 Augment `README'. 10 years ago
Ludovic Courtès b7a7f59847 Add the usual top-level files. 10 years ago