Browse Source

gnu: Remove ffmpeg@3.3.

The reason this was required was because of a regression in ffmpeg 3.4; see
<https://trac.ffmpeg.org/ticket/6775>.

* gnu/packages/gstreamer.scm (gst-libav)[inputs]: Change FFMPEG-3.3 to FFMPEG.
* gnu/packages/video.scm (ffmpeg-3.3): Remove variable.
python-updates
Marius Bakke 5 years ago
parent
commit
f419fe4ddb
No known key found for this signature in database GPG Key ID: A2A06DF2A33A54FA
  1. 2
      gnu/packages/gstreamer.scm
  2. 13
      gnu/packages/video.scm

2
gnu/packages/gstreamer.scm

@ -402,7 +402,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("ffmpeg" ,ffmpeg-3.3)
("ffmpeg" ,ffmpeg)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "http://gstreamer.freedesktop.org/")

13
gnu/packages/video.scm

@ -762,19 +762,6 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
;; XXX: Remove this when gst-libav and qtox supports 3.4.
(define-public ffmpeg-3.3
(package
(inherit ffmpeg)
(version "3.3.5")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
"00nq8ng2p16yb48acargaz1hlp9kq24vfwvkqjlslz4a7864k4x8"))))))
(define-public ffmpeg-2.8
(package
(inherit ffmpeg)

Loading…
Cancel
Save