Browse Source

build: Require Guile 2.2.3 or later.

* configure.ac: For 2.2.x, require 2.2.3 or later.
gn-latest-20200428
Ludovic Courtès 2 years ago
parent
commit
e688c2df39
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
  1. 6
      configure.ac

6
configure.ac

@ -96,7 +96,11 @@ dnl 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([3.0 2.2])
GUILE_PROGS
if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
AC_MSG_ERROR(['guild' binary not found; please check your Guile installation.])
fi
if test "x$GUILE_EFFECTIVE_VERSION" = "x2.2"; then
PKG_CHECK_MODULES([GUILE], [guile-2.2 >= 2.2.3])
fi
dnl Installation directories for .scm and .go files.

Loading…
Cancel
Save