Browse Source

build: Require Guile >= 3.0.3.

Fixes <https://issues.guix.gnu.org/53157>.
Reported by Efraim Flashner <efraim@flashner.co.il>.

* configure.ac: Require Guile >= 3.0.3.
* doc/guix.texi (Requirements): Update accordingly.
wip-python-mne
Ludovic Courtès 7 months ago
parent
commit
d582b39978
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
  1. 3
      configure.ac
  2. 3
      doc/guix.texi

3
configure.ac

@ -102,6 +102,9 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your Guile installation.])
fi
dnl (guix ui), notably, requires 'default-optimization-level' added in 3.0.3.
PKG_CHECK_MODULES([GUILE], [guile-3.0 >= 3.0.3])
dnl Get CFLAGS and LDFLAGS for libguile.
GUILE_FLAGS

3
doc/guix.texi

@ -894,7 +894,8 @@ GNU Guix is available for download from its website at
GNU Guix depends on the following packages:
@itemize
@item @url{https://gnu.org/software/guile/, GNU Guile}, version 3.0.x;
@item @url{https://gnu.org/software/guile/, GNU Guile}, version 3.0.x,
version 3.0.3 or later;
@item @url{https://notabug.org/cwebber/guile-gcrypt, Guile-Gcrypt}, version
0.1.0 or later;
@item

Loading…
Cancel
Save