Browse Source

gnu: octave: Update to 4.4.1.

* gnu/packages/maths.scm (octave): Update to 4.4.1.
(qtoctave)[source]: Remove obsolete patch.
* gnu/packages/patches/qtoctave-qt-5.11-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
wip-ipfs
Kei Kebreau 4 years ago
parent
commit
b66741edc9
No known key found for this signature in database GPG Key ID: E6A5EE3C19467A0D
  1. 1
      gnu/local.mk
  2. 11
      gnu/packages/maths.scm
  3. 26
      gnu/packages/patches/qtoctave-qt-5.11-fix.patch

1
gnu/local.mk

@ -1097,7 +1097,6 @@ dist_patch_DATA = \
%D%/packages/patches/qemu-glibc-2.27.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtoctave-qt-5.11-fix.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \

11
gnu/packages/maths.scm

@ -1350,12 +1350,12 @@ can solve two kinds of problems:
@end enumerate\n")
(license license:bsd-3)))
;; For a fully featured Octave, users are strongly recommended also to install
;; For a fully featured Octave, users are strongly recommended also to install
;; the following packages: less, ghostscript, gnuplot.
(define-public octave
(package
(name "octave")
(version "4.4.0")
(version "4.4.1")
(source
(origin
(method url-fetch)
@ -1363,7 +1363,7 @@ can solve two kinds of problems:
version ".tar.lz"))
(sha256
(base32
"0nm766737gbkq9wqry54a026k3dg7rb1065kngfpwgjz8b544xbp"))))
"0jsdgizlv02an2ppfjwk5qf209zpwi3317yb7jvlsjzxnir3lvhy"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
@ -1433,10 +1433,7 @@ script files.")
(package (inherit octave)
(name "qtoctave")
(source (origin
(inherit (package-source octave))
(patches (append (origin-patches (package-source octave))
(search-patches
"qtoctave-qt-5.11-fix.patch")))))
(inherit (package-source octave))))
(inputs
`(("qscintilla" ,qscintilla)
("qt" ,qtbase)

26
gnu/packages/patches/qtoctave-qt-5.11-fix.patch

@ -1,26 +0,0 @@
This patch comes from upstream:
https://hg.savannah.gnu.org/hgweb/octave/rev/cdaa884568b1.
# HG changeset patch
# User Mike Miller <mtmiller@octave.org>
# Date 1527214835 25200
# Node ID cdaa884568b159549bd373f04386ff62417f6df9
# Parent 9e39a53b4e007d3f79f88b711ab9fa5f2f24fbc9
add Qt include needed to build against Qt 5.11 (bug #53978)
* settings-dialog.cc: Add missing include for <QButtonGroup> to fix build
failure with Qt 5.11.
diff --git a/libgui/src/settings-dialog.cc b/libgui/src/settings-dialog.cc
--- a/libgui/src/settings-dialog.cc
+++ b/libgui/src/settings-dialog.cc
@@ -34,6 +34,8 @@
#include "workspace-model.h"
#include "settings-dialog.h"
#include "ui-settings-dialog.h"
+
+#include <QButtonGroup>
#include <QDir>
#include <QFileInfo>
#include <QFileDialog>
Loading…
Cancel
Save