Browse Source

inferior: Adjust for Guile 2.0.

Partly fixes <https://bugs.gnu.org/32326>.
Reported by Michael Bowcutt <mbowcutt@riseup.net>.

* guix/inferior.scm (open-inferior): Wrap 'setvbuf' call in 'cond-expand'.
wip-ipfs
Ludovic Courtès 3 years ago
parent
commit
a81b59b1bf
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
  1. 5
      guix/inferior.scm

5
guix/inferior.scm

@ -87,7 +87,10 @@ equivalent. Return #f if the inferior could not be launched."
(define pipe
(inferior-pipe directory command))
(setvbuf pipe _IOLBF)
(cond-expand
((and guile-2 (not guile-2.2)) #t)
(else (setvbuf pipe 'line)))
(match (read pipe)
(('repl-version 0 rest ...)
(let ((result (inferior 'pipe pipe (cons 0 rest))))

Loading…
Cancel
Save