Browse Source

self: 'package-for-guile' really honors GUILE-VERSION.

* guix/self.scm (package-for-guile): Pass GUILE-VERSION to
'false-if-wrong-guile'.
gn-latest-20200428
Ludovic Courtès 3 years ago
parent
commit
a1639ae9de
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      guix/self.scm

+ 1
- 1
guix/self.scm View File

@ -69,7 +69,7 @@ GUILE-VERSION (\"2.0\" or \"2.2\"), or #f if none of the packages matches."
(#f
(loop rest))
((? package? package)
(or (false-if-wrong-guile package)
(or (false-if-wrong-guile package guile-version)
(loop rest))))))))
(define specification->package


Loading…
Cancel
Save