Browse Source

packages: 'fold-available-packages' uses 'supported-package?'.

Fixes <https://bugs.gnu.org/37748>.
Reported by Marius Bakke <mbakke@fastmail.com>.

This is a followup to d2d63e20d5.

* gnu/packages.scm (fold-available-packages): Use 'supported-package?'
instead of (member ... (package-supported-systems ...)) to match what
'generate-package-cache' does.
gn-latest-20200428
Ludovic Courtès 2 years ago
parent
commit
88da011592
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
  1. 4
      gnu/packages.scm

4
gnu/packages.scm

@ -228,9 +228,7 @@ package module."
#:outputs (package-outputs package)
#:location (package-location package)
#:supported?
(->bool
(member (%current-system)
(package-supported-systems package)))
(->bool (supported-package? package))
#:deprecated?
(->bool
(package-superseded package))))

Loading…
Cancel
Save