Browse Source

build-self: Accomodate upgrades from May 2016 and earlier.

Reported by Paul Garlick <pgarlick@tourbillion-technology.com>.

Fixes a bug whereby "old" Guix instances (before mid-May 2018) would
fail to pull to current master.

Specifically, Paul reported being unable to upgrade from
6f84dc4314 (a commit that predates that
addition of the 'bootstrap' phase on gnu-build-system on 'master' and
that also predates the new 'guix pull'.)

* build-aux/build-self.scm (guile-gcrypt)[arguments]: New field.
gn-latest-20200428
Ludovic Courtès 3 years ago
parent
commit
3ffcad7df3
No known key found for this signature in database GPG Key ID: 90B11993D9AEBB5
1 changed files with 10 additions and 0 deletions
  1. +10
    -0
      build-aux/build-self.scm

+ 10
- 0
build-aux/build-self.scm View File

@ -216,6 +216,16 @@ person's version identifier."
"1gir7ifknbmbvjlql5j6wzk7bkb5lnmq80q59ngz43hhpclrk5k3"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(arguments
;; The 'bootstrap' phase appeared in 'core-updates', which was merged
;; into 'master' ca. June 2018.
'(#:phases (modify-phases %standard-phases
(delete 'bootstrap)
(add-before 'configure 'bootstrap
(lambda _
(unless (zero? (system* "autoreconf" "-vfi"))
(error "autoreconf failed"))
#t)))))
(native-inputs
`(("pkg-config" ,(specification->package "pkg-config"))
("autoconf" ,(specification->package "autoconf"))


Loading…
Cancel
Save