Browse Source

installer: Use latest Guile.

Since the installer is loading Guix modules built with Guile 3.0.4, the
installer script must be run by the same Guile version to avoid a bytecode
incompatibility.

This is a follow-up of a2991de0f4.

* gnu/installer.scm (installer-program): Use guile3.0-latest for the
installation script.
Mathieu Othacehe 1 year ago
parent
commit
3f44034e8f
No known key found for this signature in database GPG Key ID: 8354763531769CA6
  1. 3
      gnu/installer.scm

3
gnu/installer.scm

@ -440,5 +440,6 @@ selected keymap."
;; some reason, unicode support is not correctly installed
;; when calling this in 'installer-builder'.
(setenv "LANG" "en_US.UTF-8")
(execl #$(program-file "installer-real" installer-builder)
(execl #$(program-file "installer-real" installer-builder
#:guile guile-3.0-latest)
"installer-real"))))
Loading…
Cancel
Save