Browse Source

gnu: Remove all #:select from (gnu packages ...) modules.

This works around Guile bug <http://bugs.gnu.org/15540>.
Reported by Andreas Enge <andreas@enge.fr>.

* gnu/packages/engineering.scm: Don't #:select from (gnu packages ...).
* gnu/packages/gcc.scm: Likewise.
* gnu/packages/package-management.scm: Likewise.
* gnu/packages/photo.scm: Likewise.
* gnu/packages/pulseaudio.scm: Likewise.
* gnu/packages/moe.scm: Likewise, and #:select from (guix licenses)
  instead.
gn-latest-20200428
Ludovic Courtès 6 years ago
parent
commit
38cf2ba084
6 changed files with 7 additions and 7 deletions
  1. +1
    -1
      gnu/packages/engineering.scm
  2. +1
    -1
      gnu/packages/gcc.scm
  3. +2
    -2
      gnu/packages/moe.scm
  4. +1
    -1
      gnu/packages/package-management.scm
  5. +1
    -1
      gnu/packages/photo.scm
  6. +1
    -1
      gnu/packages/pulseaudio.scm

+ 1
- 1
gnu/packages/engineering.scm View File

@ -35,7 +35,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module ((gnu packages linux) #:select (eudev)) ; FIXME: for pcb
#:use-module (gnu packages linux) ;FIXME: for pcb
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)


+ 1
- 1
gnu/packages/gcc.scm View File

@ -28,7 +28,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages elf)
#:use-module ((gnu packages perl) #:select (perl))
#:use-module (gnu packages perl)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)


+ 2
- 2
gnu/packages/moe.scm View File

@ -17,9 +17,9 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages moe)
#:use-module (guix licenses)
#:use-module ((guix licenses) #:select (gpl3+))
#:use-module (gnu packages ncurses)
#:use-module ((gnu packages compression) #:select (lzip))
#:use-module (gnu packages compression)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))


+ 1
- 1
gnu/packages/package-management.scm View File

@ -26,7 +26,7 @@
#:use-module ((guix licenses) #:select (gpl2+ gpl3+ lgpl2.1+))
#:use-module (gnu packages)
#:use-module (gnu packages guile)
#:use-module ((gnu packages compression) #:select (bzip2 gzip))
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages databases)
#:use-module (gnu packages graphviz)


+ 1
- 1
gnu/packages/photo.scm View File

@ -28,7 +28,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages popt)
#:use-module (gnu packages perl)
#:use-module ((gnu packages base) #:select (tzdata)))
#:use-module (gnu packages base))
(define-public libexif
(package


+ 1
- 1
gnu/packages/pulseaudio.scm View File

@ -24,7 +24,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module ((gnu packages autotools) #:select (libltdl))
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages check)
#:use-module (gnu packages gdbm)


Loading…
Cancel
Save