Browse Source

Fix Guile version checking in the "web" code.

* guix/web.scm (http-fetch): fix Guile version checking. The previous version
would use features from Guile 2.0.9+ when using Guile 2.0.7.
gn-latest-20200428
Cyril Roelandt 9 years ago
parent
commit
16df248e4b
  1. 15
      guix/web.scm

15
guix/web.scm

@ -157,14 +157,13 @@ unbuffered port, suitable for use in `filtered-port'."
;; Try hard to use the API du jour to get an input port.
;; On Guile 2.0.5 and before, we can only get a string or
;; bytevector, and not an input port. Work around that.
(if (version>? "2.0.7" (version))
(if (defined? 'http-get*)
(http-get* uri #:decode-body? text?
#:port port) ; 2.0.7
(http-get uri #:decode-body? text?
#:port port)) ; 2.0.5-
(http-get uri #:streaming? #t
#:port port))) ; 2.0.9+
(if (version>? (version) "2.0.7")
(http-get uri #:streaming? #t #:port port) ; 2.0.9+
(if (defined? 'http-get*)
(http-get* uri #:decode-body? text?
#:port port) ; 2.0.7
(http-get uri #:decode-body? text?
#:port port)))) ; 2.0.5-
((code)
(response-code resp)))
(case code

Loading…
Cancel
Save