Browse Source

gnu: nettle: Make version 3 the default.

* gnu/packages/nettle.scm (nettle): Rename to...
  (nettle-2): ... this.
  (nettle-3): Rename to...
  (nettle): ... this.
* gnu/packages/gnutls.scm (gnutls): Use NETTLE-2.
* gnu/packages/lsh.scm (lsh): Likewise.
gn-latest-20200428
Ludovic Courtès 6 years ago
parent
commit
0be199c976
3 changed files with 7 additions and 7 deletions
  1. +1
    -1
      gnu/packages/gnutls.scm
  2. +2
    -2
      gnu/packages/lsh.scm
  3. +4
    -4
      gnu/packages/nettle.scm

+ 1
- 1
gnu/packages/gnutls.scm View File

@ -140,7 +140,7 @@ living in the same process.")
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.
`(("libtasn1" ,libtasn1)
("nettle" ,nettle)
("nettle" ,nettle-2)
("zlib" ,zlib)))
(home-page "http://www.gnu.org/software/gnutls/")
(synopsis "Transport layer security library")


+ 2
- 2
gnu/packages/lsh.scm View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -91,7 +91,7 @@ basis for almost any application.")
("gperf" ,gperf)
("psmisc" ,psmisc))) ; for `killall'
(inputs
`(("nettle" ,nettle)
`(("nettle" ,nettle-2)
("linux-pam" ,linux-pam)
;; 'rl.c' uses the 'CPPFunction' type, which is no longer in


+ 4
- 4
gnu/packages/nettle.scm View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -24,7 +24,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages m4))
(define-public nettle
(define-public nettle-2
(package
(name "nettle")
(version "2.7.1")
@ -53,10 +53,10 @@ cryptographic toolkits for object-oriented languages or in applications
themselves.")
(license gpl2+)))
(define-public nettle-3
(define-public nettle
;; This version is not API-compatible with version 2. In particular GnuTLS
;; cannot use it yet. So keep it separate.
(package (inherit nettle)
(package (inherit nettle-2)
(version "3.0")
(source (origin
(method url-fetch)


Loading…
Cancel
Save