ソースを参照

build: Allow builds with Guile 2.2.

Reported by Mu Lei.

* configure.ac: Use 'GUILE_PKG', allowing 2.2.
Use 'GUILE_PROGS' instead of 'AC_PATH_PROG'.
gn-latest-20200428
Ludovic Courtès 4年前
コミット
9d126aa2b5
この署名に対応する既知のキーがデータベースに存在しません GPGキーID: 90B11993D9AEBB5
1個のファイルの変更11行の追加3行の削除
  1. +11
    -3
      configure.ac

+ 11
- 3
configure.ac ファイルの表示

@@ -74,14 +74,22 @@ dnl We require pkg.m4 (from pkg-config) and guile.m4 (from Guile.)
dnl Make sure they are available.
m4_pattern_forbid([PKG_CHECK_MODULES])
m4_pattern_forbid([GUILE_MODULE_AVAILABLE])
m4_pattern_forbid([^GUILE_P$])

PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
AC_PATH_PROG([GUILE], [guile])
AC_PATH_PROG([GUILD], [guild])
dnl Search for 'guile' and 'guild'. Prefer 2.0 until the 2.2 upgrade is
dnl complete.
GUILE_PKG([2.0 2.2])
GUILE_PROGS
if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
fi

if test "x$GUILE_EFFECTIVE_VERSION" = "x2.0"; then
PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
else
AC_MSG_WARN([Guile $GUILE_EFFECTIVE_VERSION is not fully supported!])
fi

dnl guile-json is used for the PyPI package importer
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])


読み込み中…
キャンセル
保存