Pārlūkot izejas kodu

build: Prefer Guile 2.2 over 2.0.

* configure.ac: In 'GUILE_PKG', prefer 2.2 over 2.0.  Remove warning
about 2.2 not being fully supported.
* doc/guix.texi (Requirements): Mention Guile 2.2.x.
gn-latest-20200428
Ludovic Courtès pirms 3 gadiem
vecāks
revīzija
608e42e7c9
Šim parakstam datu bāzē netika atrasta zināma atslēga GPG atslēgas ID: 90B11993D9AEBB5
2 mainītis faili ar 5 papildinājumiem un 6 dzēšanām
  1. +3
    -5
      configure.ac
  2. +2
    -1
      doc/guix.texi

+ 3
- 5
configure.ac Parādīt failu

@@ -73,9 +73,9 @@ m4_pattern_forbid([PKG_CHECK_MODULES])
m4_pattern_forbid([GUILE_MODULE_AVAILABLE])
m4_pattern_forbid([^GUILE_P$])

dnl Search for 'guile' and 'guild'. Prefer 2.0 until the 2.2 upgrade is
dnl complete. This macro defines 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([2.0 2.2])
dnl Search for 'guile' and 'guild'. This macro defines
dnl 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([2.2 2.0])
GUILE_PROGS
if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
@@ -83,8 +83,6 @@ fi

if test "x$GUILE_EFFECTIVE_VERSION" = "x2.0"; then
PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
else
AC_MSG_WARN([Guile $GUILE_EFFECTIVE_VERSION is not fully supported!])
fi

dnl Installation directory for .scm and .go files.


+ 2
- 1
doc/guix.texi Parādīt failu

@@ -551,7 +551,8 @@ in the Guix source tree for additional details.
GNU Guix depends on the following packages:

@itemize
@item @url{http://gnu.org/software/guile/, GNU Guile}, version 2.0.7 or later;
@item @url{http://gnu.org/software/guile/, GNU Guile}, version 2.0.7 or
later, including 2.2.x;
@item @url{http://gnupg.org/, GNU libgcrypt};
@item
@uref{http://gnutls.org/, GnuTLS}, specifically its Guile bindings


Notiek ielāde…
Atcelt
Saglabāt