Sfoglia il codice sorgente

build: Depend on guile-ssh 0.12.0

This is a followup to 35f3511167.

* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Check for userauth-gssapi!
* doc/guix.texi: Document version requirement

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
gn-latest-20200428
Lars-Dominik Braun 7 mesi fa
committed by Ludovic Courtès
parent
commit
3789187252
Non sono state trovate chiavi note per questa firma nel database ID Chiave GPG: 90B11993D9AEBB5
2 ha cambiato i file con 5 aggiunte e 4 eliminazioni
  1. +2
    -2
      doc/guix.texi
  2. +3
    -2
      m4/guix.m4

+ 2
- 2
doc/guix.texi Vedi File

@@ -772,11 +772,11 @@ The following dependencies are optional:

@itemize
@item
@c Note: We need at least 0.10.2 for 'channel-send-eof'.
@c Note: We need at least 0.12.0 for 'userauth-gssapi!'.
Support for build offloading (@pxref{Daemon Offload Setup}) and
@command{guix copy} (@pxref{Invoking guix copy}) depends on
@uref{https://github.com/artyom-poptsov/guile-ssh, Guile-SSH},
version 0.10.2 or later.
version 0.12.0 or later.

@item
When @url{https://www.nongnu.org/lzip/lzlib.html, lzlib} is available, lzlib


+ 3
- 2
m4/guix.m4 Vedi File

@@ -142,13 +142,14 @@ dnl GUIX_CHECK_GUILE_SSH
dnl
dnl Check whether a recent-enough Guile-SSH is available.
AC_DEFUN([GUIX_CHECK_GUILE_SSH], [
dnl Check whether 'channel-send-eof' (introduced in 0.10.2) is present.
dnl Check whether 'userauth-gssapi!' (introduced in 0.12.0) is present.
AC_CACHE_CHECK([whether Guile-SSH is available and recent enough],
[guix_cv_have_recent_guile_ssh],
[GUILE_CHECK([retval],
[(and (@ (ssh channel) channel-send-eof)
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval))])
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!))])
if test "$retval" = 0; then
guix_cv_have_recent_guile_ssh="yes"
else


Caricamento…
Annulla
Salva