aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpjotrp2016-02-13 17:02:51 +0100
committerpjotrp2016-02-13 17:02:51 +0100
commita845a58dfe0f3b87c3fc9ecb94849859263eae14 (patch)
tree0b8d582b626e8c195e0c77a2357074a0075bd2ed
parent1e17bd966f2d03287208000d5da08dc0b6947f61 (diff)
downloadguix-bioinformatics-a845a58dfe0f3b87c3fc9ecb94849859263eae14.tar.gz
Add python-parallel
-rw-r--r--gn/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 70d10f9..8f2bc80 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -387,6 +387,33 @@ project)")
(description #f)
(license #f)))
+(define-public python2-parallel
+ (package
+ (name "python2-parallel")
+ (version "1.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.parallelpython.com/downloads/pp/pp-" version ".zip"
+ ))
+ (sha256
+ (base32
+ "1bw3j0zn7bj56636vp1vx4m91p2mlp661gn2nfhpbph3prgxzv82"))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+
+ (build-system python-build-system)
+ ;; (native-inputs
+ ;; `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f
+ )) ; no 'setup.py test' really!
+ (home-page #f)
+ (synopsis "Parallel python lib")
+ (description #f)
+ (license #f)))
(define-public python2-numarray
(package