Browse Source

Updating site with ruby 2.3.1

remotes/origin/live
Pjotr Prins 3 years ago
parent
commit
c1a9a756db
5 changed files with 29 additions and 166 deletions
  1. +1
    -0
      .gitignore
  2. +5
    -18
      Gemfile
  3. +21
    -0
      Gemfile.dev
  4. +0
    -146
      Gemfile.lock
  5. +2
    -2
      INSTALL.md

+ 1
- 0
.gitignore View File

@@ -1,3 +1,4 @@
Gemfile.lock
pkg/
contrib/
*.swp


+ 5
- 18
Gemfile View File

@@ -1,21 +1,8 @@
source "http://rubygems.org"

gem "middleman", "~>3.2.0"
gem "rb-inotify"
gem "therubyracer"
gem "middleman-livereload"
gem "middleman"


# Add dependencies to develop your gem here.
# Include everything needed to run rake, tests, features, etc.
group :development do
# Live-reloading plugin
gem "middleman-livereload", "~> 3.1.0"
# For faster file watcher updates on Windows:
gem "wdm", "~> 0.1.0", :platforms => [:mswin, :mingw]
# Javascript
gem 'execjs'
gem 'therubyracer'
gem "rake"
gem "yard", "~> 0.7"
gem "rspec", "~> 2.5"
gem "nokogiri", "~> 1.5"
gem "cucumber", "~> 1.2"
gem "thread", "~> 0.1.3"
end

+ 21
- 0
Gemfile.dev View File

@@ -0,0 +1,21 @@
source "http://rubygems.org"

gem "middleman"

# Add dependencies to develop your gem here.
# Include everything needed to run rake, tests, features, etc.
group :development do
# Live-reloading plugin
gem "middleman-livereload", "~> 3.1.0"
# For faster file watcher updates on Windows:
gem "wdm", "~> 0.1.0", :platforms => [:mswin, :mingw]
# Javascript
gem 'execjs'
gem 'therubyracer'
gem "rake"
gem "yard", "~> 0.7"
gem "rspec", "~> 2.5"
gem "nokogiri", "~> 1.5"
gem "cucumber", "~> 1.2"
gem "thread", "~> 0.1.3"
end

+ 0
- 146
Gemfile.lock View File

@@ -1,146 +0,0 @@
GEM
remote: http://rubygems.org/
specs:
activesupport (3.2.22)
i18n (~> 0.6, >= 0.6.4)
multi_json (~> 1.0)
builder (3.2.2)
chunky_png (1.3.4)
coffee-script (2.2.0)
coffee-script-source
execjs
coffee-script-source (1.9.1.1)
compass (1.0.3)
chunky_png (~> 1.2)
compass-core (~> 1.0.2)
compass-import-once (~> 1.0.5)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
sass (>= 3.3.13, < 3.5)
compass-core (1.0.3)
multi_json (~> 1.0)
sass (>= 3.3.0, < 3.5)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
cucumber (1.3.20)
builder (>= 2.1.2)
diff-lcs (>= 1.1.3)
gherkin (~> 2.12)
multi_json (>= 1.7.5, < 2.0)
multi_test (>= 0.1.2)
diff-lcs (1.2.5)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
eventmachine (1.0.8)
execjs (1.4.1)
multi_json (~> 1.0)
ffi (1.9.10)
gherkin (2.12.2)
multi_json (~> 1.3)
haml (4.0.7)
tilt
hike (1.2.3)
http_parser.rb (0.6.0)
i18n (0.6.11)
json (1.8.3)
kramdown (1.9.0)
libv8 (3.16.14.13)
listen (1.3.1)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
rb-kqueue (>= 0.2)
middleman (3.2.2)
coffee-script (~> 2.2.0)
compass (>= 0.12.2)
execjs (~> 1.4.0)
haml (>= 3.1.6)
kramdown (~> 1.2)
middleman-core (= 3.2.2)
middleman-sprockets (>= 3.1.2)
sass (>= 3.1.20)
uglifier (~> 2.4.0)
middleman-core (3.2.2)
activesupport (~> 3.2.6)
bundler (~> 1.1)
i18n (~> 0.6.9)
listen (~> 1.1)
rack (>= 1.4.5)
rack-test (~> 0.6.1)
thor (>= 0.15.2, < 2.0)
tilt (~> 1.4.1)
middleman-livereload (3.1.1)
em-websocket (>= 0.2.0)
middleman-core (>= 3.0.2)
multi_json (~> 1.0)
rack-livereload
middleman-sprockets (3.3.3)
middleman-core (>= 3.2)
sprockets (~> 2.2)
sprockets-helpers (~> 1.1.0)
sprockets-sass (~> 1.1.0)
mini_portile (0.6.2)
multi_json (1.11.2)
multi_test (0.1.2)
nokogiri (1.6.6.2)
mini_portile (~> 0.6.0)
rack (1.6.4)
rack-livereload (0.3.16)
rack
rack-test (0.6.3)
rack (>= 1.0)
rake (10.4.2)
rb-fsevent (0.9.6)
rb-inotify (0.9.5)
ffi (>= 0.5.0)
rb-kqueue (0.2.4)
ffi (>= 0.5.0)
ref (2.0.0)
rspec (2.99.0)
rspec-core (~> 2.99.0)
rspec-expectations (~> 2.99.0)
rspec-mocks (~> 2.99.0)
rspec-core (2.99.2)
rspec-expectations (2.99.2)
diff-lcs (>= 1.1.3, < 2.0)
rspec-mocks (2.99.4)
sass (3.4.19)
sprockets (2.12.4)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sprockets-helpers (1.1.0)
sprockets (~> 2.0)
sprockets-sass (1.1.0)
sprockets (~> 2.0)
tilt (~> 1.1)
therubyracer (0.12.2)
libv8 (~> 3.16.14.0)
ref
thor (0.19.1)
thread (0.1.7)
tilt (1.4.1)
uglifier (2.4.0)
execjs (>= 0.3.0)
json (>= 1.8.0)
yard (0.8.7.6)

PLATFORMS
ruby

DEPENDENCIES
cucumber (~> 1.2)
execjs
middleman (~> 3.2.0)
middleman-livereload (~> 3.1.0)
nokogiri (~> 1.5)
rake
rspec (~> 2.5)
therubyracer
thread (~> 0.1.3)
wdm (~> 0.1.0)
yard (~> 0.7)

BUNDLED WITH
1.10.6

+ 2
- 2
INSTALL.md View File

@@ -17,14 +17,14 @@ set the environment with my
script. E.g.

```sh
guix install ruby rake ruby-nokogiri bundler
guix install ruby rake ruby-nokogiri
. ruby-guix-env
gem install bundler
cd biogems.info # source dir
bundle
```

You may want to install bundler which is needed for middleman.
You need to install bundler which is needed for middleman.

A 'quick' test run



Loading…
Cancel
Save